Resolving an "Error Contains Filter Wrong Type" Issue

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The Issue in Riva Cloud or Riva On-Premise

The following error appears in the sync logs:

Error - Error occurred clearing items: an internal server error occurred:  [Error Contains Filter Wrong Type] The Contains filter can only be used for string properties.
Unable to initialize: an internal server error occurred: [Error Contains Filter Wrong Type] The Contains filter can only be used for string properties.

 

Cause

Some Exchange versions support searching with the "Contains" filter, while other versions do not. When using an affected version of Exchange Server, the error appears in the sync log when Riva tries to search items by category.

Solution

The solution depends on the Riva platform:

Solution for Riva Cloud

Solution for Riva On-Premise

  1. In the Riva Manager application, double-click the Microsoft Exchange connection to edit it.

  2. On the Connection Details tab, hold the CTRL key and double-click the Host: label next to the URL field.

    Result: A window opens and displays the path and custom settings file for the Exchange connection.

  3. Close the Exchange connection window and the Riva Manager application.

  4. Open the Custom.settings file in an ASCII text editor like Notepad. If the file does not exist, create a file and copy the default contents into the new .config file.

  5. In the Custom.settings file, add the following line:

    <add key="Sync.Ex.ExchangeVersionSupportsContainsFilterOnCategoryOverride" value="False">

  6. Save and close the file.

Note: The Sync.Ex.ExchangeVersionSupportsContainsFilterOnCategoryOverride advanced option is used by Riva only if it is added to the Exchange custom settings. It will not be used if it is added to the sync policy's Advanced Options tab or to the CRM custom settings file.

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