Sugar: PHP Compatibility Issue With PHP 5.3

  • Updated

Background

The Sugar SOAP Web Services APIs are used to exchange data between Riva and Sugar. Many Linux distributions include PHP 5.3 or higher as the default version of PHP.

If you are running an older version of Sugar SOAP Web Services APIs, it might not support PHP 5.3.

Even though Sugar 6.0 was certified with compatibility for PHP 5.3, full compatibility was not available until version 6.0.1.

For Riva, PHP 5.3 is incompatible with ALL versions of Sugar prior to 6.0.1.

Solution

Do one of the following:

  • To use Riva with Sugar with PHP 5.3, upgrade to Sugar 6.3.1 at the very least. See https://web.sugarcrm.com/support/issues and search for "38990" (without the quotation marks); or
  • (Not recommended.) Downgrade PHP to 5.2.x on the Sugar server.

Was this article helpful?

/

Comments

0 comments

Article is closed for comments.