Applies to both platforms of Riva (Cloud and On-Premise).
Issue
In Outlook, a user drags and drops an email into a SmartConvert folder, specifically the - Create New Order or - Create New Quote folder, and the following sync error occurs:
Cause
The configuration for creating an order or quote in NetSuite is incomplete.
Solution
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In NetSuite, create an item and take note of its internal ID.
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Do one of the following:
- For Riva Cloud, contact the Riva Success Team.
- For Riva On-Premise, apply the appropriate advanced option to the NetSuite connection.
Step 1: In NetSuite, create an item's Internal ID
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Sign into NetSuite as an Administrator.
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Select Lists >> Accounting >> Items.
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In the Items tab, on the New drop down, select Inventory Item.
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In the Inventory Item window, select Create a New Item, and select Save.
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Take note of the item's automatically generated internal ID.
Note: The ID is required when updating Riva's sync policy. To create orders and quotes, you need two items: one for orders and the other for quotes. To create a second item, repeat steps 3 and 4. Take note of both internal IDs.
Step 2: In Riva On-Premise, apply the appropriate advanced option to the NetSuite connection
Note: For Riva Cloud, contact the Riva Success Team.
For Riva On-Premise, do the following:
- In the Riva Manager application, apply the appropriate advanced option to the NetSuite connection.
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For an order, apply NetSuite.SalesOrder.DefaultLineItemId = n
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For a quote, apply NetSuite.Quote.DefaultLineItemId = n
where n is the item's internal ID from the NetSuite Inventory.
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