Issue
The following error may occur in a user sync log:
Cause
This error indicates that the Access > Lists -> Events permission is not set to Full for the target user or connection user account in NetSuite.
Solution
By default, Riva Cloud connects to NetSuite as the target user and uses the connection user’s primary NetSuite role as the effective web services role. If the NetSuite connection user is not a NetSuite administrator, the web services role may not have sufficient permissions to create, edit, or delete events in the NetSuite events list.
To resolve this issue:
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Determine on which account to perform the rest of the procedure:
- For individual Riva Cloud users and Riva Cloud Company subscriptions: on the NetSuite user account for the target user
- For Riva Cloud Corporate subscriptions: on the NetSuite user account for the Riva Cloud NetSuite connection.
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Log in to NetSuite as an admin account.
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Navigate to Setup > Users/Roles > Manage Users.
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Edit the target user or connection user, and determine the user’s primary role.
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Navigate to Setup > Users/Roles > Manage Roles.
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Edit the user’s primary role.
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Select the Access tab and the Lists tab. Confirm that the Full permission is assigned to the Events list.
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Save the role.
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Wait for Riva Cloud to sync, and test to see if events are now syncing properly.
If the error persists, contact the Riva Cloud Success Team to report the issue.