Riva Cloud Error: NetSuite: You Need a Higher Level of the 'Lists -> Events' Permission

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Issue

The following error may occur in a user sync log:

Error - Operation failed: User does not hold the necessary privileges to perform the operation, [Code=INSUFFICIENT_PERMISSION] Permission Violation: You need a higher level of the 'Lists -> Events' permission to access this page. Please contact your account administrator.. Please Check The User's permission.

 

Cause

This error indicates that the Access Lists -> Events permission is not set to Full for the target user or connection user account in NetSuite.

Solution

By default, Riva Cloud connects to NetSuite as the target user and uses the connection user’s primary NetSuite role as the effective web services role. If the NetSuite connection user is not a NetSuite administrator, the web services role may not have sufficient permissions to create, edit, or delete events in the NetSuite events list.

To resolve this issue:

  1. Determine on which account to perform the rest of the procedure:

    • For individual Riva Cloud users and Riva Cloud Company subscriptions: on the NetSuite user account for the target user
    • For Riva Cloud Corporate subscriptions: on the NetSuite user account for the Riva Cloud NetSuite connection.
  2. Log in to NetSuite as an admin account.

  3. Navigate to Setup > Users/Roles > Manage Users.

  4. Edit the target user or connection user, and determine the user’s primary role.

  5. Navigate to Setup > Users/Roles > Manage Roles.

  6. Edit the user’s primary role.

  7. Select the Access tab and the Lists tab. Confirm that the Full permission is assigned to the Events list.

  8. Save the role.

  9. Wait for Riva Cloud to sync, and test to see if events are now syncing properly.

If the error persists, contact the Riva Cloud Success Team to report the issue.

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