Issue
In Riva Cloud (or Riva On-Premise 2.4.30 or higher), the following error may occur when attempting to sync a new or updated contact record to NetSuite.
Error - Not allowed to create contact XXX without company, because in the next sync cycle, it will be deleted by AssignedTo sync due to owner check.
Cause
The error occurs when a contact is not associated or listed with a company on NetSuite.
Solution
Riva Cloud
Riva On-Premise
To resolve the error:
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Add the following advanced option to the NetSuite connection:
NetSuite.Contact.AllowCreatesIfCompanyIsNull = True
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Locate the Subsidiary ID in NetSuite and update the NetSuite connection with the Subsidiary ID.