Issue
In Riva Cloud or Riva On-Premise, the following error may appear in the sync logs when Riva is attempting to establish a connection with the Google server.
Error - Connection to Google Server failed: [Unauthorized] (unauthorized_client) The client is not authorized to request an access token using this method
Cause
The user's Google or Gmail password has changed, but the user's email connection in Riva has not been updated.
Solution
For Riva Cloud:
- Ensure that the user re-validates the email connection with Riva.
For Riva On-Premise:
-
In the Riva Manager application, double-click the existing Google connection to edit it.
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To the left, select General. To the right, provide the correct password, verify it, and select Save.