Issue
The Exchange connection error "Unable to access shared mailbox" may occur for one of the syncing users:
Cause
This error normally occurs when a syncing user's Exchange mailbox (for example, user1@mycompany.com) is being shared with another Exchange account (for example, user2@mycompany.com).
The sharing can take place in one of these ways:
- Granting delegate access to another mailbox, or
- Being granted delegate access to another Exchange mailbox.
Solution
In this example, the Riva connection account for Exchange user1@mycompany.com needs to be granted full access permissions to the other Exchange mailbox account (user2@mycompany.com) that is involved in the Exchange shared access.
Ensure that full access permissions are provided to the Riva connection account for Exchange mailbox to the mailboxes of the target user being synced and any Exchange mailboxes that the target user has been granted delegate access to.
Applies to
- Riva for Exchange.