A customer moved Riva from Windows 2003 (x86) to Windows 2008 R2 SP1 (64-bit). The customer reported the following error when trying to perform a test connection to Exchange 2003:
2013-05-16 10:22:45,723 ERROR [3428] [(null)] MAPI initialization error. Please ensure that Outlook or the Exchange Server MAPI Client is installed, and that you have sufficient privileges to invoke them.
Omni.Connection.Exchange.x2a1ea22867edfe3f: MAPI initialization error. Please ensure that Outlook or the Exchange Server MAPI Client is installed and that you have sufficient privileges to invoke them. ---> Omni.OmniException: MAPI initialization error. Please ensure that Outlook or the Exchange Server MAPI Client is installed and that you have sufficient privileges to invoke them. ---> System.Runtime.InteropServices.COMException (0x80004005): Creating an instance of the COM component with CLSID {DB9DE7F2-B732-4107-8F4B-C150E75A719F} from the IClassFactory failed due to the following error: 80004005.
Omni.Connection.Exchange.x2a1ea22867edfe3f: MAPI initialization error. Please ensure that Outlook or the Exchange Server MAPI Client is installed and that you have sufficient privileges to invoke them. ---> Omni.OmniException: MAPI initialization error. Please ensure that Outlook or the Exchange Server MAPI Client is installed and that you have sufficient privileges to invoke them. ---> System.Runtime.InteropServices.COMException (0x80004005): Creating an instance of the COM component with CLSID {DB9DE7F2-B732-4107-8F4B-C150E75A719F} from the IClassFactory failed due to the following error: 80004005.
Customer's Riva System
Examination of the Windows system confirmed the following:
- The host Windows system is Windows 2008 R2 SP1
- Outlook 2010 64-bit is installed
- Riva is installed with a Direct MAPI connection configured.
- An Outlook profile for the Riva connection user mailbox exists and Outlook can start and access the mailbox.
Cause of the Issue
The error indicates that Riva attempted to call a COM component from Outlook and could not locate it. Riva is a 32-bit application and needs a 32-bit version of Outlook installed. Since Riva cannot locate the required 32-bit file, it failed the connection test.
Resolution
Use the following procedure:
- Remove the Outlook profile for the Riva connection user (if it exists).
- Uninstall the 64-bit version of Outlook.
- Install the 64-bit version of Outlook.
- Perform the MAPI connection test from the Riva Manager application.
Applies to
- Riva for Exchange using MAPI connections