Riva Solution For a Line Break / Carriage Return Issue (CRM & Outlook/Exchange)

  • Updated

Issue

When the descriptions of tasks or events created in Sugar or Salesforce contain line breaks and Riva Cloud or Riva On-Premise syncs the tasks or events to Exchange, the task or event descriptions in Outlook do not contain the line breaks.

Other CRMs may also be affected when syncing with Exchange.

Example:

Original text in the CRM:
TEST1.
Test2.
This is the 3rd line.

Text displayed by Outlook:
TEST1.Test2.This is the 3rd line.

Cause

A bug in Outlook's automatic conversion from plain text to RTF is causing the problems.

Riva is not changing the format. Riva does transmit the correct plain text from the CRM to Exchange.

Solution

Riva has developed a workaround that prevents the bug in Outlook from dismissing the line breaks.

Solution for Riva Cloud

To preserve the line breaks:

Solution for Riva On-Premise

To preserve the line breaks:

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