EWS Error: Unable to Connect to Server: [ErrorConnectionFailed]

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Issue

The Riva Service Monitor displays Error - Unable to connect to server [ErrorConnectionFailed], and the following error appears in the crmex-log files:

2012-09-06 10:49:53,477  INFO [CTP-giz #0] [1815628545] [XSIF] Polling for changes [?]
2012-09-06 10:50:01,680  WARN [CTP-giz #0] [1815628545] Service response error: [ErrorConnectionFailed] Connection did not succeed. Try again later.
2012-09-06 10:50:01,680  INFO [CTP-giz #0] [1815628545] [XSIF] Error - Unable to connect to server: [ErrorConnectionFailed] [?]
2012-09-06 10:50:01,680  INFO [CTP-giz #0] [1815628545] Error - Unable to connect to server: [ErrorConnectionFailed]
2012-09-06 10:50:01,680  INFO [CTP-giz #0] [1815628545] [XSIF] Poll completed [?]
2012-09-06 10:50:01,680 ERROR [CTP-giz #0] [1815628545] [XSIF] Error occurred polling for changes
Omni.Connection.Ews.EwsServerException: Unable to connect to server: [ErrorConnectionFailed] ---> Microsoft.Exchange.WebServices.Data.ServiceResponseException: Connection did not succeed. Try again later.

 

Cause

The CRM Agent Service suffers an error connecting to Exchange Web Services in the middle of a sync cycle after the initial connection is successful. This can be caused by the EWS timeout value for Riva being too short.

Solution

Do the following:

Applies to

  • Riva for Exchange using EWS connections.

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