Issue
During periods of high levels of data sync between Salesforce and Exchange, Riva Cloud or Riva On-Premise may display a REQUEST_LIMIT_EXCEEDED error.
Cause
The error indicates that the maximum number of API calls for that user for the current 24-hour period has been exceeded. For more information, see Salesforce: Connection to CRM server failed: REQUEST_LIMIT_EXCEEDED.
Discussion
By default, Riva returns 500 items per API call when it performs a query to Salesforce for data. For example, if Riva has to initialize a new target user, it must query Salesforce for all of the contacts for the organization, and Salesforce returns those results in batches of 500 contacts per API call. If there are 2640 contacts in Salesforce, Riva consumes six API calls.
Solution
Riva has a method to adjust the number of query results per API call. The higher the number of query results per API call, the fewer API calls per 24-hour period.
Solution for Riva Cloud
Solution for Riva On-Premise
To adjust the number of query results per API call to Salesforce:
-
Create or modify the app.setting file Omni.Riva.CrmAgentEx.exe.config to include the following key and a value
OR add to the CRM connection's Advanced Options:Salesforce.BatchSize = "500" (Default value.)
Tip: Increase the value of Salesforce.BatchSize to decrease the number of API calls consumed by Riva while performing large data query operations, especially when adding new target users or performing re-initialization synchronizations.
Applies to
- Riva Cloud.
- Riva On-Premise 2.4.25 or higher.