Issue
When Riva Cloud or Riva On-Premise attempts to sync multiple appointments (appointments that span two or more calendar days), an error similar to the following may occur.
Omni.Sync.ItemSyncException: [FIELD_INTEGRITY_EXCEPTION] Duration must be between 0 and 1440 minutes: Duration -- DurationInMinutes
---> Omni.Connection.Salesforce.SforceErrorResponseException: [FIELD_INTEGRITY_EXCEPTION] Duration must be between 0 and 1440 minutes: Duration -- DurationInMinutes
Cause
Salesforce is not configured for multiday-spanning appointments, but Riva is. (For Riva On-Premise, this is possible in release 2.4.31 or higher.)
Solution
The solution is the same for Riva Cloud and Riva On-Premise because it is implemented in Salesforce.
To configure Salesforce to support multiday events:
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Log in to Salesforce as an administrator.
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Select Setup > Customize > Activities > Activity Settings.
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Select the Enable Multiday Events check box, and select Submit.
After the Salesforce Enable Multiday Event option is selected, Riva can support syncing to appointments with a duration of greater than 1440 minutes (24 hours).
Applies to
- Riva Cloud.
- Riva On-Premise 2.4.31 or higher.
- Salesforce.