Private Appointments Sync Fails From Exchange to Salesforce - [FIELD_INTEGRITY_EXCEPTION] Error

  • Updated
What this article describes is no longer an issue. That is why it is now in the Archive category.

 

The customer reported that trying to sync an appointment created in Outlook and marked as "Private" displays [FIELD_INTEGRITY_ERROR] errors in the CRM Monitor.

Examination of the "cmrex-log" file reveals the following error:

2012-07-11 14:12:50,823 ERROR [CTP-qrb #0] [1LQ67ZUZ4PVK] [FIELD_INTEGRITY_EXCEPTION] Private events for other users are not allowed: Private -- IsPrivate

Omni.Sync.ItemSyncException: [FIELD_INTEGRITY_EXCEPTION] Private events for other users are not allowed: Private -- IsPrivate
 ---> Omni.Connection.Salesforce.x2c220c8fb4684d05: [FIELD_INTEGRITY_EXCEPTION] Private events for other users are not allowed: Private -- IsPrivate

 

Cause

The Riva sync policy is using a Riva connection to Salesforce that employs Standard Impersonation (non-SSO). By default, the "IsPrivate" flag with Salesforce is supported only for Riva connections to Salesforce that use Enterprise Impersonation, which uses SSO.

For more information, see Private Appointments Handling.

Resolution

Riva version 2.4.22 introduced an app.setting option to override the default support for private flags.

To override the default support for private flags:

  1. Create or modify the app.setting file "Omni.Riva.CrmAgentEx.exe.config" to include the following key and value:

    Key: Crm.Calendar.PrivatizeAppointmentsOverride Value: true

  2. Restart the CRM Agent service.

Applies to

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