The customer reported that trying to sync an appointment created in Outlook and marked as "Private" displays [FIELD_INTEGRITY_ERROR] errors in the CRM Monitor.
Examination of the "cmrex-log" file reveals the following error:
Omni.Sync.ItemSyncException: [FIELD_INTEGRITY_EXCEPTION] Private events for other users are not allowed: Private -- IsPrivate
---> Omni.Connection.Salesforce.x2c220c8fb4684d05: [FIELD_INTEGRITY_EXCEPTION] Private events for other users are not allowed: Private -- IsPrivate
Cause
The Riva sync policy is using a Riva connection to Salesforce that employs Standard Impersonation (non-SSO). By default, the "IsPrivate" flag with Salesforce is supported only for Riva connections to Salesforce that use Enterprise Impersonation, which uses SSO.
For more information, see Private Appointments Handling.
Resolution
Riva version 2.4.22 introduced an app.setting option to override the default support for private flags.
To override the default support for private flags:
-
Create or modify the app.setting file "Omni.Riva.CrmAgentEx.exe.config" to include the following key and value:
Key: Crm.Calendar.PrivatizeAppointmentsOverride Value: true
-
Restart the CRM Agent service.
Applies to
- Riva On-Premise Server release 2.4.22+
- Riva connection to Salesforce using "Standard Impersonation" - Create and Test a Connection to Salesforce