GoldMine Error: Missing or Invalid Session ID Returned: The Data Engine...

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Issue

When the Riva sync service starts and is establishes the connection to GoldMine, an error appears in the Riva Service Monitor and crmex-log file:

"Missing or invalid session iD returned: The data engine loaded successfully, but GoldMine did not create a session ID. Please use the Login command to retrieve a session ID."

Missing or Invalid Session ID returned.png

Cause

This can occur when the GoldMine license file is removed from the specified location of the system path, as per this screenshot:

GoldMine connection object.png

Solution

To make the GoldMine connection point to the local path where the GoldMine license file resides:

  1. In the Riva Manager application, on the menu bar, if you see Setup, select Setup.

  2. In the right pane, double-click the GoldMine connection object to edit the connection.

  3. Select the Options tab. Browse and select the correct path where the license file is located.

  4. Save the connection.

  5. In the Riva Service Monitor, restart the service.

  6. Verify that the error no longer appears.

 

 
 
 

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