Issue
When the Riva sync service starts and is establishes the connection to GoldMine, an error appears in the Riva Service Monitor and crmex-log file:
"Missing or invalid session iD returned: The data engine loaded successfully, but GoldMine did not create a session ID. Please use the Login command to retrieve a session ID."
Cause
This can occur when the GoldMine license file is removed from the specified location of the system path, as per this screenshot:
Solution
To make the GoldMine connection point to the local path where the GoldMine license file resides:
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In the Riva Manager application, on the menu bar, if you see Setup, select Setup.
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In the right pane, double-click the GoldMine connection object to edit the connection.
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Select the Options tab. Browse and select the correct path where the license file is located.
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Save the connection.
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In the Riva Service Monitor, restart the service.
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Verify that the error no longer appears.