Issue
(Applies to Riva 2.4.39 or higher.)
During a sync with the "Enable Completed Activity" option selected in GoldMine, the Riva Service Monitor and Riva logs for the calendar item sync display an error similar to this one:
Cause
A user completed a calendar item in GoldMine and deleted the same calendar item in Exchange. By default, Riva does not sync a GoldMine completed calendar deletion when the delete originates from Exchange.
Solution
To allow Completed calendar items to be deleted from Exchange:
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In the Riva Manager application, on the menu bar, if you see Setup, select Setup.
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In the right pane, double-click the GoldMine connection to edit it.
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In the window that appears, select the Other tab.
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in the right pane, select this check box: Enable Completed Activity Deleted from GoldMine.
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Save the connection.