Issue
(Applies to Riva 2.4.39 or higher.)
During a sync with the "Enable Completed Activity" option selected in GoldMine, the Riva Service Monitor and Riva logs for the calendar item sync display an error similar to this one:
2015-02-06 11:34:59,897 ERROR [CTP-skn #0] [FTG0AH3MIWSJ] Error - Ignoring item change due to error: Completed activity [Riva Test (oc:)] could not be removed.. [CA141]
Cause
A user completed a calendar item in GoldMine and deleted the same calendar item in Exchange. By default, Riva does not sync a GoldMine completed calendar deletion when the delete originates from Exchange.
Solution
To allow Completed calendar items to be deleted from Exchange:
- In the Riva Manager application, on the menu bar, if you see Setup, select Setup.
- In the right pane, double-click the GoldMine connection to edit it.
- In the window that appears, select the Other tab.
- in the right pane, select this check box: Enable Completed Activity Deleted from GoldMine.
- Save the connection.