Issue
In Riva Cloud or Riva On-Premise, the following Oracle CRM On Demand error may occur:
Cause
Error 1: Some Oracle CRM On Demand configurations require that a "SalesStageId" value be set when creating an opportunity. If the field is not present when creating an opportunity, the error occurs.
Error 2: Similar to error 1, a required field is missing, in this case, the user key: AccountName when creating a contact.
Solution
Error 1: Ensure that when creating opportunities, a default Sales Stage ID be provided. This setting can be defined on the connection details for the Oracle CRM On Demand connection.
Error 2: Ensure that when creating a contact, an AccountName is provided.
Note: There are some default values available for contacts and opportunities with Oracle CRM On Demand but most companies customize these values, and each CRM instance may be different.
Solution for Riva Cloud
To define the SalesStageId value in the Oracle On Demand CRM connection:
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In Riva Cloud, edit the Oracle CRM connection.
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Add the desired default Sales Stage ID.
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Save the changes.
Riva Cloud applies that value on the next sync cycle for each user.
Solution for Riva On-Premise
To define the Sales Stage ID default value:
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Start the Riva Manager application. On the menu bar, select Setup.
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In the right pane, double-click the Oracle On Demand connection.
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In the window that appears, select Options, and select the Override Opportunity SalesStage Default Value check box.
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Save the changes.
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In the CRM Monitor application, restart the service.