Applies to Riva Cloud and Riva On-Premise.
Issue
The error prevents the creation of new contacts or new appointments.
Cause
This error indicates that there is already a contact in NetSuite that has the "Firstname Lastname" combination.
NetSuite prevents the creation of multiple contacts with the same "Firstname Lastname" combination.
Typically, this is caused by a single contact using multiple email addresses and the CRM contact record has not been updated with the alternate email address.
Solution
-
Update the CRM with the additional email address.
-
Update the CRM contact record with the alternate email field.
Example
A contact with the name of "Jonathan Masters" exists in NetSuite with the primary email of j.masters@netsuite.com.
The user being synchronized by Riva has received an appointment or email from Jonathan Masters, who used his personal email address, john.master@gmail.com, instead of his business email address.
Both email addresses are legitimate, but NetSuite prevents the creation of a second contact because there is already a contact with this name.
The solution is to add the second email address to the existing contact record in the Alternate Email field in NetSuite.