Issue
When Riva Cloud or Riva On-Premise attempts to create an item in NetSuite, Riva may output a sync error in this format:
[Item type] Error - Error occurred creating item: [Code=USER_ERROR] Please enter value(s) for: Mandatory Field Name: Item title or subject
Example:
[Appointment] Error - Error occurred creating item: [Code=USER_ERROR] Please enter value(s) for: Marketing Category: Statement of Work Discussion
Cause
Riva cannot create a CRM item (for example, an appointment), because a mandatory field in the CRM create-item form cannot be populated with data; in the example, the mandatory field for a new CRM item is Marketing Category and has a subject of Statement of Work Discussion.
Possible Solutions
Possible solution #1: Customize Riva
This involves signing a professional services agreement with the Riva Client Engagement team to create a Riva server customization to auto-populate the mandatory field with a default value to meet customer requirements. This is a billable option. Contact the Riva Success Team.
Possible solution #2: Modify the create form(s) in the CRM
This involves modifying the CRM to do one of the following:
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Set the mandatory field(s) as optional (not mandatory). Users can then add the custom data after the item is created by Riva; or
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Set the mandatory field(s) to have a default value other than NULL. When Riva creates the item, NetSuite adds the default value because Riva does not specify a value; or
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Modify or create workflows in NetSuite to add value when an item is created by Riva.
Possible Solution #3: Set the default FORM for the Riva connection user
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Create a form that does not specify the field as mandatory.
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Assign this new form as the default form of the role used by the Riva connection user.
Note: When creating a new record, Riva uses the default form, which does not require a value for the field.