Issue
Riva Cloud or Riva On-Premise may fail to sync NetSuite users due to a "Permission Violation: You need the 'Lists -> Employees' permission" error.
Riva Logs
Examination of the Riva logs would reveal an error similar to this sample:
RoleId: 1022, RoleName: Sales & Support Role - BA Reps
RoleId: 1025, RoleName: Employee Center - BA
RoleId: 1045, RoleName: Sales & Support Role-web service
Cause
In this case, the NetSuite user configured in the Riva connection does not have a default web services role:
User does not hold the necessary privileges to perform the operation with roleId()
When the Riva CRM Agent service attempted to sync for the specified target user, NetSuite reported that the default role (the role that the user first logged into NetSuite with) did not have sufficient permissions. Riva indicates roleID numbers for the multiple roles assigned to the connection user.
Solution
The NetSuite user that is configured in the Riva CRM connection (Riva connection user) must be configured with a role that has sufficient permissions. There are two options:
- Assign the "Administrator Role" to the NetSuite user and specify that role as the Web Services Role, or
- Create a new NetSuite Role, configure it with sufficient permissions for Riva, assign it to the NetSuite user, and configure it as the Web Services Role.
For detailed instructions, see Prepare a Riva Connection user for NetSuite.