Issue
Riva Cloud or Riva On-Premise may fail to sync NetSuite users due to a lack of permission to access employee data.
Examination of the Riva logs would reveal an error similar to this sample:
Cause
The NetSuite user configured in the Riva connection does not have the correct permissions set up in NetSuite.
User does not hold the necessary privileges to access employee data
Solution
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Log in to NetSuite as a NetSuite administrator.
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On the Setup tab, select Users/Roles, and then choose Manage Users.
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Search for and select the NetSuite user configured in the Riva connection, and then select Edit.
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On the Access tab, select the Give Access check box.
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Under Global Permissions, give full access to the following permissions:
- Employee Record.
- Employees.
A similar error, Poll Error - Insufficient permission, [Code=INSUFFICIENT_PERMISSION] Permission Violation: You need the 'Deleted Records' permission to access this page, can be fixed by following the same steps, except that at step 5, give full access to Deleted Records.