Solution For: Updated Riva Installation Suffers Critical Error When Service is Started

  • Updated
ADVISORY: The issue described in this article occurred in Feb. 2011. If it were to occur again, ensure that your Riva server meets the requirements, especially the .NET requirements. Be advised that if Riva syncs Dynamics 365 CRM or Dynamics CRM, Riva usually needs to meet even higher .NET requirements: see Finish preparing the Host Windows system. The rest of this article has not been updated.

 

Issue

The customer previously installed Riva On-Premise configured to use an Exchange connection. After performing a "Check for Updates" to the latest release, the RivaApp.exe file suffered a critical error when Riva attempted to connect to Exchange.

Detailed technical information follows:
---
Date and Time:        2/16/2011 2:58:39 PM
Application Domain Name:    RivaApp.exe
Assembly Codebase:    file:///C:/Program Files/Omni/Riva/Application/2.4.21.10273/RivaApp.exe
Assembly Full Name:    RivaApp, Version=2.4.21.10273, Culture=neutral, PublicKeyToken=6a8e6e68587f48be
Assembly Version:    2.4.21.10273
Assembly Build Date:    2/15/2011 7:55:34 PM

(Inner Exception)
Exception Source:Omni.Connection.Microsoft
Exception Type:System.IO.FileNotFoundException
Exception Message:Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
Exception Target Site:.ctor

Cause

The system requirements for Riva CRM have been upgraded to require .Net Framework 3.5 SP1 instead of .Net Framework 2.0 SP2.  The "Check for Updates" does not check to ensure that new minimum system requirements are met.

Solution

  1. Use Windows Task Manager to ensure that Riva.exe and/or RivaApp.exe are not running as a process.

  2. Run Microsoft Update, or download and install the Microsoft .Net Framework 3.5 SP1. Do not install .Net Framework 4.x, because that will not correct the problem.

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