Error: 'Exception From HRESULT: 0x80131515' After Installing Riva On-Premise

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Issue

The following error appears in logging, or in the Riva Service Monitor:

System.IO.FileLoadException: Could not load file or assembly 'file:///C:\Program Files (x86)\Omni\Riva\Application\Base\Omni.Riva.Sdk.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)
File name: 'file:///C:\Program Files (x86)\Omni\Riva\Application\Base\Omni.Riva.Sdk.dll' ---> System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.

 

Cause

The riva-latest.zip file used to install Riva On-Premise was blocked by Windows. That means that all files extracted from that zip file were also blocked.

Solution

There are two approaches that can be taken. The first approach is less invasive; the second should be used only if the first fails.
 

  1. Use Windows Command Prompt to identify whether there are blocked files in the Riva installation directory, then use Windows PowerShell to unblock all files in that same directory.
     
  2. Reinstall Riva with an unblocked zip file.

To unblock files in a Riva installation path:
 

  1. Open Command Prompt as an administrator, then run the following command to identify whether there are any blocked files in the Riva installation folder. Files that are blocked will have Zone.Identifier appended to their names in the terminal output, which is shown with the /r option:

    dir /s /r | find "Zone.Identifier" 
     

  2.  Run the following PowerShell command (as an administrator) to unblock the files:

    dir FullFolderPathOfRivaInstallation -Recurse | Unblock-File
     

  3. Restart the Riva sync service, and confirm that the users and sync policy load & sync normally in the Service Monitor.

    If the steps above do not resolve the problem, move on to the second approach as below.
     

To reinstall Riva with an unblocked .zip file:

  1. Remove the Riva files and folders previously extracted from the blocked riva-latest.zip file.

  2. Right-click the riva-latest.zip file, and select Properties.

  3. Select Unblock, and select OK.

    UnblockRivaPackage (2).png

  4. Follow the normal procedures to extract the files from the zip file and continue setting up Riva.

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