Issue
Customer reported that Riva suffered a critical error when trying to add an Exchange 2003 MAPI connection.
A critical exception occured.
The application will now close.
Restart the application and/or contact technical support, support@omni-ts.com.
Detailed technical information follows:
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Application Domain Name: RivaApp.exe
(Inner Exception)
Exception Source:Omni.Connection.Microsoft
Exception Type:System.IO.FileNotFoundException
Exception Message:Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.
Cause
The .Net Framework is not installed.
Confirmation: The lack of .Net framework can be confirmed as follows:
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For Windows Server 2003 - open Control Panel > Add & Remove Programs and check for Microsoft .Net Framework 3.5 Service Pack 1 or higher is installed.
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For Windows 7 and Windows sever 2008 - open Control Panel > Programs > Installed Programs and check for Microsoft .Net Framework 3.5 Service Pack 1 or higher is installed.
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For Windows server 2008 R2:
- Open Server Manager > Features, and check that .Net Framework 3.5 Service Pack 1 has been activated, or
- Open Control Panel > Programs > Installed Programs, and check that Microsoft .Net Framework 4 is installed.
Resolution
Use Windows Task Manager to ensure that Riva.exe and/or RivaApp.exe is not running as a process.
Run Microsoft Update, or download and install the Microsoft .Net Framework 3.5 SP1.