Issue
The Riva sync service fails to start from the Riva Service Monitor application and from the Windows services applet (services.msc), and the latest "crmex-log" log file includes something like this:
2019-10-10 16:57:28,072 INFO [3176] [(null)] CrmService........................
2019-10-10 16:57:28,087 INFO [3176] [(null)] WARNING! Less than 100 MB of free disk space detected. Please ensure enough disk space is available for the service to continue and for logging to occur.
2019-10-10 16:57:28,103 INFO [2996] [(null)] Exiting...
The above error sample indicates that Riva is running with TRACE logging enabled, and the volume that Riva is installed on has less than 100 MB of free space left.
Instead of TRACE, the error message could have said DEBUG or VERBOSE.
Cause
Riva includes three advanced diagnostic logging levels: DEBUG, TRACE, and VERBOSE. Diagnostic logging levels are meant to be disabled when they are no longer needed. TRACE, DEBUG, and VERBOSE logging levels are very wordy and can consume considerable hard disk storage space. Riva is designed to prevent the sync service from starting if there is insufficient disk storage space.
Solution
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In the Riva\Logs folder, locate all log files that are older than one month. Move them to a different disk or location. We recommend NOT deleting them.
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Perform any normal Windows maintenance to remove unwanted files from the installation volume.
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Disable the DEBUG, TRACE, or VERBOSE logging level in one of these ways:
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Riva 2.4.42 or higher: procedure in the Riva Manager application.
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Any version of Riva: edit a .config file to disable DEBUG, TRACE, or VERBOSE logging.
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