Riva Service Monitor Does Not Start - Error: "Network Port Unavailable"

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Issue

When the following error occurs, it is not possible to start the Riva Service Monitor application:

error-opening-crmservicemonitor.png

Cause

The Riva Service Monitor application is already running, and only one instance at a time can execute on the host Windows system. If the application is not visible in the user's taskbar, then the application must be open on another logged-on user's desktop. This is common when multiple users RDP into the same Riva server.

Solution

If you need to start the Riva Service Monitor, do as follows:

  1. In the Windows Task Manager, select the Show processes from all user's check box.

  2. On the Processes tab, locate Omni.Riva.CrmMonitor.exe, and select End Process.

    force-crmsvcmonitor-close.png

    Result: The application closes, regardless of who opened it.

    It is now possible to start the Riva Service Monitor application.

Applies to

  • Riva On-Premise server (all versions).

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