Applies to Riva On-Premise.
Issue
In Riva On-Premise, one or more users fail to load in the Service Monitor with an error message:
Error adding a user to Policy: There is an error in the XML document.
The error may also appear in logging.
Cause
The error is caused when the affected users' entity.settings files become corrupted.
For more information, see Understand How Riva Maintains Transaction Records.
Solution
To resolve the error and sync the affected users:
Sync.Crm.RecreateInvalidEntitySettings = True
- Restart the sync service.
Result: The affected users will have their entity.settings files automatically recreated on the following sync cycle and will resume syncing without any other intervention.
If the steps above fail to resolve the error, contact the Riva Success Team.