Target Users Not Syncing - "System.IO.__Error.WinIOError" Error - Windows UAC

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Issue

The Riva Service Monitor starts to report that all of the target users are not syncing, and the cmrex-log file contains something like this:

2011-12-12 14:06:06,777 ERROR [CrmAgentStart] [(null)] Problem getting manager for Policy: Exchange CRM Synchronization Policy Admins
System.IO.FileNotFoundException: Could not find file 'C:\Windows\TEMP\adfohmzp.dll'.
File name: 'C:\Windows\TEMP\adfohmzp.dll'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

 

Cause

The System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)indicates a file system access issue related to User Account Control (UAC). The CRM Agent Service is not able to start, because it cannot access the C:\Windows\TEMP\ folder.

The normal practice is to configure the properties of the CRM Agent Service to log on locally as a user with the necessary permissions. If that user is not a member of the local Administrator's group, Windows UAC prevents the service from read/write access to system folders, in this case, the C:\Windows\TEMP\ folder.

Possible Solutions

Configure the CRM Agent Service to log on as the correct user

Set the Logon Identity for the CRM Agent Service:

Disable UAC

To turn off UAC:

  1. In Windows, select Start, and then select Control Panel.

  2. In the Control Panel, select User Accounts.

  3. In the User Accounts window, select User Accounts.

  4. In the User Accounts tasks window, select Turn User Account Control on or off.

  5. If UAC is currently configured in Admin Approval Mode, the User Account Control message appears. Select Continue.

  6. Clear the Use User Account Control (UAC) to help protect your computer check box, and then select OK.

  7. Select Restart Now to apply the change right away, or select Restart Later, and then close the User Accounts tasks window.

Reference Documentation

Recommended reference: User Account Control Step-by-Step Guide. (Microsoft Technet.)

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