Riva Data Sync Error: Missing Master Item ID For Occurrence

  • Updated

A customer reported seeing the a "[CA] Error - Missing master item ID for occurrence" in the CRM Monitor application for a specific user.

Error in the Log

Examination of the crmex-log file revealed the following error:

2013-08-31 18:46:35,396 ERROR Missing master item ID for occurrence.
Omni.Sync.ItemSyncException: Missing master item ID for occurrence.
 
[CA] Error - Missing master item ID for occurrence.: FW: Discuss structure and contracts necessary for MS [XA418]

 

Cause

This error indicates that there is a recurring appointment titled “FW: Discuss structure and contracts necessary for MS” and Riva cannot find the original appointment in the series. This means that Riva was not able to find the "parent" appointment to a recurring series in the user's Exchange mailbox when trying to update one of the child entries.

Solution

The way to fix this issue is to find the original appointment in the Exchange series and update it.

Applies to

  • Riva for Exchange

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