Riva reported a MAPI_E_NOT_FOUND access permission error for a user mailbox that was previously syncing:
2015-01-14 12:22:29,489 ERROR [CTP-cem #70] [38WYC2I8YHOG] Error occurred retrieving SOURCE_KEY property - attempting to extract from EntryID. Please Check User's access permission.
System.Runtime.InteropServices.COMException (0x8004010F): Error in IMsgStore::OpenEntry - 0x000000008CA881F822E67D4EB0290C4F3F7D258D0100475F51F99ACE974A95FE8AAF0CA8E7A0000000A816BC0000: MAPI_E_NOT_FOUND
System.Runtime.InteropServices.COMException (0x8004010F): Error in IMsgStore::OpenEntry - 0x000000008CA881F822E67D4EB0290C4F3F7D258D0100475F51F99ACE974A95FE8AAF0CA8E7A0000000A816BC0000: MAPI_E_NOT_FOUND
Possible causes
- The Riva connection user for the EWS connection has been added to the AD Domain Admins group. If this happens, the same error will happen for all of the syncing users.
-
Delegate Full Access permissions have been removed for the Riva connection user so that impersonation will fail. Check assigned permissions:
Cause
Examination of the user mailbox in Exchange confirmed that the Delegate Full Access permissions to the Riva connection user for EWS had been removed.
Resolution
Once the permissions were re-assigned, data sync resumed as expected.