Issue
One or more of the following errors appear in Riva sync logs:
2015-02-11 09:19:38,806 INFO [CTP-wdf #4] [398H9DQWM9CAR] Total Synchronization Time: 9 secs. (9:19:38 AM)
2015-02-11 09:19:38,806 INFO [CTP-wdf #4] [398H9DQWM9CAR] Synchronization Completed in 9 secs. (9:19:38 AM)
2015-02-11 09:19:38,806 ERROR [CTP-wdf #4] [398H9DQWM9CAR] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: [XT] Previous folder ID does not match current folder ID. A reinitialization is required ---> Omni.Sync.Crm.Exchange.MismatchedFolderIdException: [XT] Previous folder ID does not match current folder ID. A reinitialization is required
or
2015-02-11 09:19:38,806 INFO [CTP-wdf #4] [398H9DQWM9CAR] Total Synchronization Time: 9 secs. (9:19:38 AM)
2015-02-11 09:19:38,806 INFO [CTP-wdf #4] [398H9DQWM9CAR] Synchronization Completed in 9 secs. (9:19:38 AM)
2015-02-11 09:19:38,806 ERROR [CTP-wdf #4] [398H9DQWM9CAR] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: [XA] Previous folder ID does not match the current folder ID. A reinitialization is required ---> Omni.Sync.Crm.Exchange.MismatchedFolderIdException: [XA] Previous folder ID does not match current folder ID. A reinitialization is required
or
Cause
For each syncing user, Riva maintains a transaction record that records the folder IDs in the user's mailbox where items are stored. Contacts are stored in address book folders, tasks are stored in To-Do List folders, and calendar items are stored in a Calendar folder. All of those folders are assigned a unique folder ID. Riva uses those folder IDs to locate the folder in the mailbox to search for items and to save items. If an issue is discovered with folder IDs, an error is issued.
Those errors indicate that the folder IDs that Riva has a record of syncing items into during previous sync cycles no longer match the folder ID that Riva is now seeing. This error is considered critical, so Riva automatically stops syncing any data and stops the sync cycle.
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[XT] Previous folder ID does not match the current folder ID - Indicates that the current folder ID for Tasks does not match the previous folder ID.
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[XA] Previous folder ID does not match the current folder ID - Indicates that the current folder ID for Appointments (actually all calendar items) does not match the previous folder ID.
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[XOpp] Previous folder ID does not match the current folder ID - Indicates that the current folder ID for Opportunities does not match the previous folder ID.
Note: It is important to understand Log Prefixes (XT, XA, Xopp, etc.)
Solution
- For Riva Cloud, contact the Riva Success Team.
- For Riva On-Premise, use this link instead, to contact the Riva Success Team.
Applies to
- Riva Cloud.
- Riva On Premise.