Issue
In Riva Cloud or Riva On-Premise, the following error may appear in the sync logs and prevent the related item from syncing.
Error - Error occurred assigning references to item: User must have a mailbox for name resolution operations: [Name of the item that is causing the issue]
Cause
One or more of the participants on the appointment, task, or item that is attempting to sync do not have an existing or proper email mailbox registered to them in the CRM.
Solution
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Ensure that
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Every participant's CRM profile includes an email address.
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The email address in the CRM matches the participant's email address in the email system.
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