Issue
A customer reported that a previously working Riva server started to report connection errors for every target user. Examination of the crmex-log file revealed:
Omni.Connection.Ews.x86553da961a3d285: Unable to connect to remote Exchange server.
Investigation
An investigation revealed that the Windows system hosting Riva could resolve the URL specified in the connection and it did match the IP address that was returned with a NSLOOKUP. The customer was able to use a web browser to log in to OWA as the Riva connection user from the Riva server.
Cause
The customer finally determined that the issue resulted from implementing an Exchange CAS Windows Network Load balancing solution that Riva cannot connect to.
Solution
In the Windows system hosting Riva, the customer added a HOSTS entry to resolve the URL to the IP address of one of the CAS servers.