Salesforce: INVALID_LOGIN Error "Invalid Username, Password, Security Token; or User Locked Out"

  • Updated

Cause

This error indicates that the user's Salesforce credentials are invalid, the security token was reset, or the user has been locked.

Solution

Update Riva Cloud with new credentials

To update the Salesforce connection credentials:

  1. In Riva Cloud, on the menu bar, select Dashboard.

  2. Near the Salesforce logo, select Update CRM Connection Settings.

  3. In the Connection Edit window, provide the updated and correct password. If you have a security token, add it to the end of the password.

  4. Fill out the other required fields, and submit the form.

Upgrade to OAuth to avoid future credential issues

OAuth is an alternative way of allowing third-party application access to Salesforce without needing to manage passwords. With OAuth, trust is established between Riva and Salesforce — removing the need to manage credentials.

To upgrade your Salesforce connection to OAuth, see Modify an existing Riva Cloud connection for Salesforce to use OAuth.

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