(Applies to Riva Cloud and Riva On-Premise.)
Issue
Selecting a Contact Web Address link or the Edit or View link (see Add Edit / View links to Outlook contacts) in the ConnectBar for Microsoft Dynamics CRM 2011 opportunity or case summary emails may cause a "404 File or Directory not found" browser error.
Checking the URLs for items reveals that the working URL for an item would be something like
https://mscrm2011.mycompany.com:444/main.aspx?etc=3&extraqs=%3f_gridType%3d3%26etc%3d3%26id%3d%257b5A19A8BD-F3BF-E111-AC9D-000C2946AFFB%257d%26rskey%3d751178779&pagetype=entityrecord
while the URL in the Riva-generated URL for an item would look like
https://mscrm2011.mycompany.com:444/CRM-Organization-name/SFA/opps/edit.aspx?id=5a19a8bd-f3bf-e111-ac9d-000c2946affb
Cause
The Riva-generated URL included the Organization Name in the path.
Solution for Riva Cloud
Solution for Riva On-Premise
-
Apply the following advanced option to the CRM connection:
MSCRM.IncludeOrgNameInUrl = False (The Riva-generated URL now excludes the Organization Name in the path.)
-
To correct previously synced items, select the Resync re-init option while re-initializing all items.
Applies to
- Riva Cloud.
- Riva On-Premise 2.4.25.11927 or higher.
- Riva for Microsoft Dynamics CRM 2011+.