Issue
You may not be able to create a connection to a Sugar server, even when you can log in to your CRM account in a browser. Attempts to create the connection using the CRM connection URL would return "Error while testing connection before saving".
Possible Causes
The Riva Cloud servers must be able to connect to the CRM or email system or service URL from the public internet. Typical causes of the "Error while testing connection before saving" error include:
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The URL is not accessible from the public internet.
The user may be able to log in and access their CRM account because the URL works in the user's private network, but it is not visible from the internet due to firewall restrictions or an improper DNS domain name, for example, https://crm.example.local -
The URL is not using https.
Riva Cloud is configured to protect the credentials of user names and passwords. All connections must be SSL encrypted so that only https:// URLs are permitted. -
The SSL certificate is not publicly trusted.
Many organizations assign self-signed SSL certificates to the web server that hosts their email or CRM service. While that certificate may be trusted in an internal network, it is not trusted by the public internet. Riva Cloud requires that SSL certificates be signed by a public Certificate Authority like Verisign.
Determine the Exact Cause
From a computer that is accessing the public internet (not in the internal network), open a web browser (Firefox is recommended because it provides the most details when it encounters an error), and type in the URL for the connection, for example https://crm.example.com.
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If the browser reports that it cannot locate the website, then the URL is not visible on the public internet.
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If the browser reports that it cannot connect to the https:// URL, try using an http:// URL, for example, http://crm.example.com. If you see a login page, then the CRM website is not protected by an SSL certificate.
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If the browser reports a certificate error,
check to see if the error is that the SSL certificate is not trusted.Firefox actually shows the details of the error, for example, "The certificate is not trusted because it is self-signed."
Solution
To resolve those connection issues:
- Ensure that the URL for the CRM or email system
- It is available from the public internet, and
- It is protected by a publicly trusted SSL certificate. If the SSL certificate is self-signed, purchase a public SSL certificate from a commercial Certificate Authority, and bind that certificate to the web service hosting the CRM or email system.
Applies to
- Riva Cloud CRM connections.
- Riva Cloud Exchange Web Service connections.