Issue
The Riva Cloud sync logs, the Riva On-Premise logs, or the Riva On-Premise CRM monitor display the following error:
Cause
According to Sugar's password expiration policies, when the Riva connection service user password expires, the connection is eventually locked out and Riva cannot be granted impersonation access to user accounts.
Possible Solutions
Use one of the following approaches to manage password expiration for the Riva connection user to the CRM:
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Set the passwords in Sugar not to expire, OR
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Set up notifications to allow the administrator to be notified when the error occurs:
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For Riva On-Premise, see The Email Notification tab;
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For Riva Cloud, see Step 1 - Configure Historic Item Filtering; OR
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Schedule a recurring task to change the password of the Riva connection CRM service user account before the password is scheduled to expire.