Solutions For: CRM Agent Service Keeps Stopping

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Issue

Some customers have reported that the CRM Agent service that Riva uses to sync data between Exchange and the CRM keeps stopping for no reason. In most cases, this occurs when a Direct MAPI or Profile MAPI connection is being used, or if Riva is installed on a Windows 2008 server with UAC enabled.

Symptoms

Several symptoms may present themselves:

  • In the Riva CRM Monitor application, the Start button is enabled and there is no sync activity in the user activity monitor windows.

  • In Windows services (services.msc), the Omni Riva CRM Agent for Exchange service is stopped or displays "Stopping".

  • The Riva crmex-log file shows a "System.IO.__Error.WinIOError" error.

Causes

Riva uses the Microsoft Messaging API (MAPI) to connect to Microsoft Exchange 2003 or to Exchange 2007/2010 by using MAPI or Outlook Anywhere. The underlying API is very fragile and, from time to time, when network communication degrades or errors occur, the API stops responding. Riva detects the API's condition and restarts the process to clear any of the memory/threads locked by the API. This type of issue is usually very specific to the Exchange system configuration.

Windows User Access Control can also affect how the Riva CRM Agent responds when syncing data.

Resolutions / Best Practises Configurations

For MAPI connections

When dealing with Direct MAPI or Outlook Profile MAPI connections, ensure that the following configuration steps are implemented:

  1. Configure the CRM Agent Service to start automatically.
  2. Configure the CRM Agent Service recovery options to restart the service for all service failures.
  3. For Direct MAPI connectionsset the CRM Agent Service Log On Identity, or
    For Outlook Profile MAPI connectionsset the CRM Agent Service Log On Identity

For Windows UAC

If the CRM Monitor reports the "System.IO.__Error.WinIOError" error, implement the corrective actions discussed in Target users not syncing - "System.IO.__Error.WinIOError" error - Windows UAC

Service is stuck in "Stopping" mode

If the CRM Agent service is displaying the "Stopping ..." status in the Windows services applet (services.msc), the resolution consists of forcing the service to stop.

Applies to

  • Riva for Exchange - all versions
  • Riva for GroupWise - all versions

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