Fix For: Fails to Connect to Dynamics CRM 2016 On-Premises

  • Updated

Issue

Earlier versions of Riva On-Premise (2.4.41 or lower, 2.4.42.33656 or lower, or 2.4.43.33658 or lower) may fail to connect to a Dynamics CRM server after it is upgraded to Dynamics CRM 2016. The following error occurs:

CRM2016-Error2(1).png

If a connection test is performed in the Riva Manager application, the following error appears:

CRM2016-Error1.png

Cause

Riva uses .DLL files from the Microsoft Dynamics CRM SDK (software development kit). Microsoft Dynamics CRM 2016 requires newer versions of two of those .DLL files which are also dependent on .NET 4.5.2.

Applies to

This issue applies to Riva connecting to Microsoft Dynamics 2016 on-premises.

Note: Riva continues to connect with Dynamics Online hosted through Office 365.

Upgrade Riva On-Premise for Dynamics 2016+ Compatibility

Audience: Riva administrators.

Upgrade Riva to add compatibility for on-premises Microsoft Dynamics CRM 2016 servers.

To upgrade older versions of Riva for Dynamics 2016+ compatibility:

  1. Determine which Riva On-Premise version is installed.

  2. Upgrade the Windows server hosting Riva to use .NET 4.5.2 or higher.

Was this article helpful?

/

Comments

0 comments

Article is closed for comments.