Microsoft Dynamics CRM Error: Connection to CRM Server Failed: [CannotImpersonate] Unable to Find User to Impersonate

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Issue

The following error may occur when trying to configure a connection to one of these versions of Dynamics CRM.

Connection to CRM Server failed: [CannotImpersonate] Unable to find user to impersonate

 

Cause

The user configured in Riva to connect with Microsoft Dynamics CRM may not be linked to an active user in Active Directory. When "Active Directory" authentication is used for Dynamics CRM, the connection user configured in Riva must be configured with a valid CRM system user with a configured link to Active Directory.

Solution

The user must first be created in Active Directory Users and Computers and then linked to the appropriate account in Dynamics CRM.

To link the user from Active Directory to the appropriate account in Dynamics CRM:

  1. Ensure that you have the System Administrator security role or equivalent permissions in Microsoft Dynamics CRM.

  2. Log in to Microsoft Dynamics with an administrator account.

  3. On the NAV bar, select Microsoft Dynamics CRM -> Settings.

  4. Select Administration -> Users.

  5. On the list of users, select the user record you want to update and select Edit.

  6. In the User Name text box, enter an Active Directory user name that is not used by any CRM user record. Use one of the following formats: "user@domain.com" or "domain\username".

  7. Select Save and Close.

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