Issue
A CRM connection error appeared in the CRM Monitor for an Infor CRM (Saleslogix) CRM user. Examination of the crmex-log file revealed the following error:
2012-01-23 05:00:27,784 INFO [CTP-rjr #824] [1551644140] Establishing connection to Exchange [test.user@mycompany.com]..
2012-01-23 05:00:40,907 INFO [CTP-rjr #824] [1551644140] Establishing connection to Saleslogix Connection [IMPERSONATION]...
2012-01-23 05:00:40,907 INFO [CTP-rjr #824] [1551644140] No match found based on email test.user@mycompany.com
2012-01-23 05:00:41,188 INFO [CTP-rjr #824] [1551644140] Connection to CRM Server failed: User 'Test_User' (Test_User) could not be found by CurrentUserID query.
2012-01-23 05:00:41,485 ERROR [CTP-rjr #824] [1551644140] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: User 'Test_User' (Test_User) could not be found by CurrentUserID query. ---> System.UnauthorizedAccessException: User 'Test_User' (Test_User) could not be found by CurrentUserID query.
2012-01-23 05:00:40,907 INFO [CTP-rjr #824] [1551644140] Establishing connection to Saleslogix Connection [IMPERSONATION]...
2012-01-23 05:00:40,907 INFO [CTP-rjr #824] [1551644140] No match found based on email test.user@mycompany.com
2012-01-23 05:00:41,188 INFO [CTP-rjr #824] [1551644140] Connection to CRM Server failed: User 'Test_User' (Test_User) could not be found by CurrentUserID query.
2012-01-23 05:00:41,485 ERROR [CTP-rjr #824] [1551644140] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: User 'Test_User' (Test_User) could not be found by CurrentUserID query. ---> System.UnauthorizedAccessException: User 'Test_User' (Test_User) could not be found by CurrentUserID query.
Cause
In this case, Riva On-Premise cannot locate a matching user in the Saleslogix system for the target Exchange user specified on the General page of the sync policy.
- No match found based on email test.user@mycompany.com indicates that a user with a matching primary email address cannot be located.
- Connection to CRM Server failed: User 'Test_User' (Test_User) could not be found by CurrentUserID query indicating that attempts to locate a matching Saleslogix user based on a suitable Saleslogix user name failed.
Solution
In Infor CRM (Saleslogix), locate the corresponding user (or create a user in Infor CRM (Saleslogix)), and configure the primary email address to use the matching the primary SMTP Reply-to email address for the corresponding target Exchange user.
For more information, see Prepare the target user accounts in Saleslogix.
Applies to
- Riva On-Premise for Exchange and Infor CRM (Saleslogix).