Applies to Riva Insight Server On-Premise.
Issue
Riva Insight displays errors similar to the ones below:
Riva Insight WebAPI logs also show an error:
Potential Causes
- The CRM connection file path in \Insight\webApp.config may be incorrect, missing, or commented out.
Example string:
- If the CRM connection file path has changed, the old connection file path may remain in the server-side cache.
Solution
To verify the CRM connection file path in Riva Insight:
- Open the webApp.config file and copy the file path from Sync.Compatibility.connectionFilePath.
- Paste the file path into a browser window. If the file opens, the path statement is correct.
- If the file does not open, copy the correct file path from the the CRM connection file:
- In Windows Explorer, navigate to \Riva\Configuration\name-of-CRM-connection-file
- While holding the Shift key, right-click the CRM connection file, then select Copy as path in the context menu.
- Paste the correct path into the value for Sync.Compatibility.connectionFilePath in the key as above, and save the file.
- In Windows Explorer, navigate to \Riva\Configuration\name-of-CRM-connection-file
To clear the server-side cache:
On the server:
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Stop IIS.
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Clear the contents of C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files.
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Start IIS.
On the client machine (repeat for each user/client):
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In Riva Insight, click the Logout icon.
Note: If using Windows AD, you are auto-logged back in, which is expected.
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Optional (should not be required, but can try if still experiencing issues): Clear the browser cache. If using Outlook as the client, open Internet Explorer to clear the cache.
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Close Outlook or the browser — close all of the browser's windows.
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Reopen Outlook or the browser.
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If required, log back into Riva Insight.