Insight.Auth.Salesforce.Oauth Not Configured

  • Updated

Applies to Riva Insight On-Premise Server.

Issue

Riva Insight displays an error message similar to the following:

Failed to retrieve information from the SDK Insight.Auth.Salesforce.Oauth not configured.

 

Cause

This error is the result of mismatched configuration in \Insight\App_Data\AppSettings.xml and \Insight\webConnectionStrings.config.

To use Login with SalesforceAppSettings.xml must have a key and value enabled (uncommented) in the following format:

 <add key="/Insight/Auth/Options" value="Salesforce" /> 


If that key is enabled,  webConnectionStrings.config should also have the correct Salesforce connection string enabled. 

Solution

Ensure that webConnectionStrings.config has the correct string enabled (uncommented) & that the cache is cleared.

  1. On the Riva Insight server, check that the \Insight\webConnectionStrings.config file has the string below enabled (uncommented) in the following format:
<add name="Insight.Auth.Salesforce.Oauth" connectionString="Key=YOUR-KEY-HERE;Secret=YOUR-SECRET-HERE;CallBackUrl=#InsightURL#/salesforce-oauth;CustomDomainAuthUrl=YOUR-SALESFORCE-DOMAIN"/>


Note: If you're not using a custom Salesforce domain, for the CustomDomainAuthUrl URL:

  • use https://login.salesforce.com; or
  • use https://test.salesforce.com if using a sandbox account

For more information about the correct configuration of this string, see Riva Insight Server: Authentication Error When Using Login with Salesforce.

  1.  If the error persists after step 1, clear the browser cache on the Riva Insight server.

    Note: The browser dependency differs based on the Insight server version.
    1. These versions use Microsoft Edge:
      • 2021.4 or higher; 
      • 2021.3 build 79884 or higher;
      • 2021.2 build 79885 or higher.

              All other versions use Internet Explorer.

  1. Restart IIS.

Result: Riva Insight Login with Salesforce is enabled.

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