Applies to Riva Insight Server (Login with Salesforce), when using a proxy to filter web traffic.
Issue
When an end user attempts to login to Riva Insight using Salesforce authentication, the following message appears:
Connection Error
There was an issue contacting Salesforce.
Additional information:
There was an error authenticating you. Authentication error occurred. Error verifying OAuth token.
Please contact your Riva Administrator.
There was an issue contacting Salesforce.
Additional information:
There was an error authenticating you. Authentication error occurred. Error verifying OAuth token.
Please contact your Riva Administrator.
Riva Insight server logging may show this message:
ERROR [11] [(null)] [CL: AuthSalesforce; M:Authenticate] [SFAuthError] System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Cause
If a CRM connection used by Insight Server has a proxy set, the proxy connection string needs to be added to the Insight server settings as well.
Solution
- On the Insight server, add this key to webConnectionStrings.config with the correct values:
<add name="Insight.HttpProxy" connectionString="Address={AddressUri};BypassProxyOnLocal={True|False};UseDefaultCredentials={True|False};UserName={UserName};Password={Password};Domain={Domain};" />
- Restart IIS Server.
If the issue persists, contact the Riva Success Team.