Issue in Riva Insight
The following error appears in the Riva Insight panel when creating a contact or updating a field:
Create failed. Error: [INVALID_FIELD_FOR_INSERT_UPDATE] Unable to create/update fields: Example_Name__c. Please check the security settings of this field and verify that it is read/write for your profile or permission set. -- Example_Name__c
Cause
This error occurs when Riva Insight is attempting to set the field in question, but the user does not have permission to access it.
Solution
Ensure that the permissions are set in two places:
-
In your CRM, verify if the field in question has limited access, and have that field made available to the CRM users. For directions, select the name of your CRM:
-
In Riva Insight, ensure that users have create and/or update permissions for the appropriate CRM records. For more information, see Manage CRM records directly from Riva Insight: configuration.