Solution For: We Don't Support This Browser. Try Opening This Page in a Supported Browser

  • Updated

Applies to Riva Insight, when using the Outlook Windows add-in and Login with Salesforce.

Issue

Upon logging into Riva Insight Windows add-in with Salesforce user name and password, the following error message appears:


 

We don't support this browser. Try opening this page in a supported browser.

 

The logs may also display an error message:

You can't access Lightning Experience.

 

Cause

The Riva Insight Windows add-in versions prior to 2021.4 use Internet Explorer as the embedded web browser. Extended support for Internet Explorer was deprecated by Salesforce Lightning as of December 31, 2021, and has already been phased out for some organizations unless they request an extension.

Solution

Recommended: Upgrade to the Windows add-in version 2021.4, which supports Edge Chromium (WebView2) as the embedded web browser.

Alternative solution: Web Add-ins for Microsoft Outlook on Windows use Microsoft Edge, provided that you are using the minimum required versions of Microsoft Windows and Microsoft Office. Additionally, Web Add-ins are also supported on Outlook for Mac, Outlook Mobile (for iOS and Android), and Outlook on the Web. Riva provides an Outlook Web Add-in version of Riva Insight. Refer to Which Riva Insight Outlook Add-in Is for You? to learn more about the differences between the Riva Insight add-ins.

To switch to the Riva Insight Outlook Web Add-in:

  1. In the Windows Control Panel, uninstall the Insight Windows add-in.

  2. Install the Riva Insight Outlook Web add-in.

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