Riva Insight: Error Occurred: Incomplete Configuration Provided For Custom Object Type: Custom1

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Issue

In the Riva Insight Context View (Windows add-in), an error similar to the one below is displayed:

Error occurred: Incomplete configuration provided for custom object type: Custom1

 

Cause

The CRM connection may not be loading the custom settings.  Here are some potential causes:

  • The custom settings were corrupted or deleted;
  • The CRM connection metadata was not refreshed after deploying a custom configuration.

Solution

  1. Check that the custom.settings file is present:
  • On the Riva server, navigate to the \Riva\Custom\Connection$folder\en\settings\ folder.

The custom.settings file should reside in that folder. Open the file with a binary text editor, and ensure that the custom keys are present between the XML tags. Here is an example:

<ConfigurationSettings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Settings>
    <add key="Crm.Salesforce.EventRelations.MultiAttendee.Enabled" value="true" />
    <add key="Crm.Salesforce.EventSubTypeValue" value="Event" />
    <add key="Crm.Salesforce.IncludePrimaryContactAsAttendee.Disabled" value="true" />
    <add key="Crm.Salesforce.TaskSubTypeValue.Email" value="Email" />
    <add key="Crm.Salesforce.TaskSubTypeValue.Task" value="Task" />
    <add key="Sync.Crm.AuthenticatedUserIsExclusiveServiceAccount" value="true" />
  </Settings>
  <Groups />
</ConfigurationSettings>

  • If the file is missing or corrupted, restore a backup by opening the file in a binary text editor. Do not use a word processing program.
     
  • Rename the backup file to Custom.settings, saving as type All Files.
  1. Follow the directions at Review or Update Configured Salesforce Metadata Fields.

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